Paquete .Deb

Con alguna frecuencia es necesario instalar paquetes de software que no se encuentran almacenados en repositorios conocidos por el sistema operativo, en este caso lo habitual es descargar el paquete .deb e instalarlo manualmente..

sudo dpkg -i paquete.deb

En caso de tener dependencias, la instalación del paquete quedará pendiente hasta que se instalen. Por ejemplo, para la instalación de Virtualbox es necesario garantizar antes la instalación de los siguientes paquetes.

dpkg: problemas de dependencias impiden la configuración de virtualbox-6.0: virtualbox-6.0 depende de libqt5opengl5 (>= 5.0.2); sin embargo: El paquete libqt 5opengl5' no está instalado. virtualbox-6.0 depende de libqt5printsupport5 (>= 5.0.2); sin embargo: El paquetelibqt5printsupport5′ no está instalado. dpkg: error al procesar el paquete virtualbox-6.0 (–install)

Solución: apt-get -f install luego de haber intentado dpkg -i paquete.deb

Instalar manualmente el paquete local recién descargado.  Como este paquete tiene dependencias su instalación no puede ser completada aún.

$ sudo dpkg -i paquete.deb

Utilizar aptitude (o apt-get) para que automáticamente instale los paquetes que sean necesarios para completar la instalación del paquete anterior.

$ sudo aptitude -f install